Back to overview
Resolved
All services unavailable
Mar 21, 2025 at 5:36pm UTC
Resolved
Mar 21, 2025 at 7:04pm UTC
All services back online, no further interruption to operation is expected
Affected services
Updated
Mar 21, 2025 at 5:48pm UTC
Main server node "Jupiter" shut down to conserve power and will come back online once it has reconnected to the grid.
Affected services
Created
Mar 21, 2025 at 5:36pm UTC
Current local power outages have led to no internet. Issue will be resolved once power returns, intermittent availability can be expected in the meantime.
Affected services