Back to overview
Resolved
Electricity Faults
Jul 20, 2025 at 10:35am UTC
Affected services
CDN
Resolved
Jul 23, 2025 at 8:32pm UTC
Issues should be resolved - Nothing has come up recently.
Affected services
Created
Jul 20, 2025 at 10:35am UTC
Due to electrical storms in the area and a fault with UK Power Networks, some interruptions can be expected.
This might degrade performance and accessibility until it's resolved.
Affected services