Back to overview
Resolved
Electricity Outage
Nov 12, 2025 at 7:29am UTC
Resolved
Nov 12, 2025 at 2:36pm UTC
Fediverse instance is now back up.
Affected services
Created
Nov 12, 2025 at 7:29am UTC
Brief electricity outage has caused some degradation of my Fedi instance. It should recover by the end of today.
Affected services