Back to overview
Maintenance

Systems Maintenance

Nov 28 at 09:30pm GMT  –  Nov 29 at 12:00am GMT
Affected services
CDN
Website
Bluesky PDS
Forgejo

Resolved
Nov 28 at 11:11pm GMT

Maintenance for Jupiter is complete. Saturn is ongoing and should be fully operational shortly.

Created
Nov 28 at 09:30pm GMT

Both nodes are going down for maintenance temporarily.

As part of this maintenance, Saturn will get some dedicated storage as opposed to using what Jupiter has - Improving reliability, so even if Jupiter goes down, Saturn should keep running.

Alongside this, Jupiter is getting a new cooling system. This isn't expected to improve or worsen performance, availability or reliability and is purely a maintenance-related change